openEuler操作系统是否支持安装Gitlab?

操作系统:openEuler-22.03-LTS-SP1-x86_64
软件下载地址:https://mirrors.tuna.tsinghua.edu.cn/gitlab-ce/yum/el7/gitlab-ce-16.1.2-ce.0.el7.x86_64.rpm

[root@localhost ~]# rpm -ivh gitlab-ce-16.1.2-ce.0.el7.x86_64.rpm
warning: gitlab-ce-16.1.2-ce.0.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID f27eab47: NOKEY
error: Failed dependencies:
        policycoreutils-python is needed by gitlab-ce-16.1.2-ce.0.el7.x86_64
[root@localhost ~]# yum search policycoreutils-python
Last metadata expiration check: 3:22:42 ago on Wed 19 Jul 2023 06:02:08 AM UTC.
================================================================= Name Matched: policycoreutils-python ==================================================================
policycoreutils-python-utils.noarch : Policy core python utilities for selinux
[root@localhost ~]# yum install policycoreutils-python-utils.noarch
Last metadata expiration check: 3:22:55 ago on Wed 19 Jul 2023 06:02:08 AM UTC.
Package policycoreutils-python-utils-3.3-4.oe2203sp1.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!

已安装依赖,但安装gitlab依旧提示缺失。

极狐gitlab目前是支持欧拉系统的,您可以参考官方文档介绍:支持的操作系统 | 极狐GitLab

你可以尝试在这里下载rpm包安装:Nexus Repository Manager